Microsoft Office Forums

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 05-10-2010, 06:01 PM
sumdumgai sumdumgai is offline Excel Error Loading Custom UI XML Windows XP Excel Error Loading Custom UI XML Office 2007
Novice
Excel Error Loading Custom UI XML
 
Join Date: May 2010
Posts: 7
sumdumgai is on a distinguished road
Default Excel Error Loading Custom UI XML


I tried to customize the Quick Access Toolbar for a workbook named 'fname_test.xlsm' by adding an icon that runs a macro (Macro1). When I close the workbook and reopen it, I get the following error. When I answer 'OK' to the message, the icon is not there. Any help would be appreciated:

Error found in Custom UI XML:

Error Loading Custom UI XML
Line 1:
Column: 480
Error Code 0x80004005
A name contained an invalid character.
Error parsing
‘fname_test.xlsm_Macro1’ as QName datatype.
The attribute ‘idQ’ with value
‘fname_test.xlsm_Macro1’ failed to parse.

I think this is related to KB969682. I would test by uninstalling this KB but the Control Panel doesn't list this patch as installed even though when I try to reinstall it, an error message says that it is already installed.

I am running Office 2003 and 2007 and have been doing so for years without problem.

I've attached a test workbook that shows the problem. Rename the extension to xlsm to run it.

Any help would be much appreciated.
Attached Files
File Type: zip test.zip (16.8 KB, 4 views)
Reply With Quote
  #2  
Old 05-10-2010, 06:59 PM
sumdumgai sumdumgai is offline Excel Error Loading Custom UI XML Windows XP Excel Error Loading Custom UI XML Office 2007
Novice
Excel Error Loading Custom UI XML
 
Join Date: May 2010
Posts: 7
sumdumgai is on a distinguished road
Default

More info. Here is the xml code being parsed:

<mso:customUI xmlns:doc="http://schemas.microsoft.com/office/...urrentDocument" xmlns:mso="http://schemas.microsoft.com/office/...ls><mso:button idQ="doc:test1_1" visible="true" label="test1" onAction="test1" imageMso="ListMacros"/><mso:button idQ="doc:test2_1" visible="true" label="test2" onAction="test2" imageMso="ListMacros"/><mso:button idQ="doc:C:_Users_ed_Desktop_test.xlsm_test3_1" visible="true" label="test3" onAction="C:\Users\ed\Desktop\test.xlsm!test3" imageMso="ListMacros"/></mso:documentControls></mso:qat></mso:ribbon></mso:customUI>

If I edit out the highlighted in red "C:_Users_ed_Desktop_test.xlsm_" and the "C:\Users\ed\Desktop\test.xlsm!" for macro test3 as I have already done for macros test1 and test2, the workbook opens without error and the QAT buttons are there and work.

For some reason, the "C:\..." location imformation is being generated and not being parsed correctly.
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excel Error Loading Custom UI XML Excel Open throws 0x800A03EC error sword.fish Excel 1 06-10-2010 09:23 AM
Excel Error Loading Custom UI XML Error Bars Excel 2007 arthos8 Excel 1 01-30-2010 12:27 PM
Excel Error Loading Custom UI XML Office loading help Patrick Office 1 11-24-2009 03:46 PM
Error When loading Apps In Office Rude Office 0 04-29-2009 03:35 AM
Excel Error Loading Custom UI XML error on start up of excel 2000 vinayak koli Excel 1 02-11-2009 05:38 AM

Other Forums: Access Forums - Senior Forums

All times are GMT -7. The time now is 03:07 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft