Microsoft Office Forums Unable To Get Proper Merged Results

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 04-11-2016, 01:00 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default Unable To Get Proper Merged Results

I have a merged report that relies on an Excel worksheet for its data.
In most part, the mail merge document merges the data correctly. I have 8 tables that share the same structure as far as the 5 mail merge fields go found in each table. The fields are all calculated the same, with only their mail merge field names differing from one table to another.

Despite copying the mail merge formula to each respective field between the 8 different tables, and changing the respective mail merge field names, I am getting inconsistent results on a few. The data is consistent, and all the header rows match the merge fields as far as I can tell.

I have attached the mail merge document (DT15v1_5.docx), the data source (Workbook "Aug-30 (Sun) schedule_3.xlsx" Worksheet "CORE") and a reference document showing all the 8 sections and their mail merge fields so that the formula can be easily read and modified.

In both the mail merge document and the reference document, the "code" in red is what is being misrepresented in the mail merge document. The fields in black are all correct.

I am wondering if someone would be so kind as to take a look at these problems and try to isolate their cause? I've copied, and reedited each several times and only ever get the wrong presentation. If I can offer more information to assist, please ask.

Thank you all in advance.
Attached Files
File Type: docx DT15v1_5.docx (413.5 KB, 4 views)
File Type: docx merge fields.docx (34.6 KB, 5 views)
File Type: xlsx Aug-30 (Sun) schedule_3.xlsx (23.0 KB, 5 views)
Reply With Quote
  #2  
Old 04-11-2016, 03:57 PM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Hi Jenn,

The problem with a number of your fields is that there is no space after the '=' sign. While it's possible to get away without a space before the '=' sign when there's a field brace preceding it, you need it to separate the sign from the text you're testing against. FWIW, you'd have had none of this trouble if you'd simply copy & pasted the field codes I gave you, then merely changed the mergefield names. It's not apparent to me the checkbox fields have an error.

See attached.
Attached Files
File Type: docx DT15v1_5.docx (410.2 KB, 12 views)
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #3  
Old 04-11-2016, 04:42 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

Hi Paul,

Happy to see your help!

While I don't doubt your advice, what I fail to understand is why my formula works in one field, I copy it to another, change the field names accordingly and get different results? ie ... look at the two formula in TS2 and TS4. Other than the r2 / r4 they are identical. Neither of them have the spaces you had suggested. I've tried rewriting the formula by inserting spaces after the "=" and don't see a change.

TS2


TS4


There is one field that was inserted using Word's "Insert Mail Merge Field". Can't really screw that up, yet it's giving me a "0" instead of WPE (as per the datasource). Didn't require any editing on my part. All the others work having used the same method.



Quote:
you'd have had none of this trouble if you'd simply copy & pasted the field codes I gave you, then merely changed the mergefield names
This is the first time you have seen this report with these fields I'm having trouble with. You had provided me me great assistance with another report in dealing with time fields. You will notice that I'm not having issues with those fields. I copied and pasted your time fields and merely changed the the references. These fields I'm having problems with now ... this is the first I've shared these particular fields with you.

I've applied the data source and SQL to your report and regrettably I see no difference. Here is what I'm seeing. (this is your report) The red is still indicating where the wrong information is presented. This shows in both the preview and final document.



The two red checkboxes should have the X in them. The rule is if = "REL" then box is of the checked type. Both fields in the datasource = "REL"

Confused. I'm not sure I'm grasping what you're sharing.
Reply With Quote
  #4  
Old 04-11-2016, 05:35 PM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

There is only one record that conforms to those specs - on row 33. The attached shows what I get for that record with the document attached to my last post.
Attached Files
File Type: docx 42246001.docx (386.9 KB, 2 views)
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #5  
Old 04-11-2016, 06:19 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

Yes ... only one record.

Can there any explanation why you are getting the proper results and I'm getting messed up mixed results? I swear my results are as I present them ... the last thing I want to do is waste both our time.

The image you attached ... is it from the same merge document you attached in your previous post with no edits since? As we both have the same data, and we're both using your report, one would think the results would be the same?

Reply With Quote
  #6  
Old 04-11-2016, 06:27 PM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

The attachment is the actual merged output from the record concerned. Your image is what I'd expect to see from your version of the mailmerge main document.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #7  
Old 04-11-2016, 06:35 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

Quote:
The attachment is the actual merged output from the record concerned.
Using the report you provided? Because the one you had attached earlier is the one I used to provide the image? Could you have mistakenly attached my incorrect report, because I'm not getting the same results from your attached report with the same data. All I'm getting is the same problems I started with.

Would you be able to attach the mail merge document you got these results with?
Reply With Quote
  #8  
Old 04-11-2016, 06:49 PM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

The mailmerge main document I got the results with is already attached to post #2, using your data file from post #1.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #9  
Old 04-11-2016, 07:03 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

OK ...
I'll download again and apply my data to it and see what I get.

I've done that already though and got the results I posted in #3. This is why I'm so confused. I don't know why we're getting different results when using the same resources.
Reply With Quote
  #10  
Old 04-11-2016, 07:37 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

Using the report you provided in #2 (reattached), with no changes ... simply downloaded, put in my folder, opened and data applied with SQL, I've attached the final document.

Some corrections, but some new and pre-existing inconsistencies. (highlighted in yellow.

In a totally separate process, I copied the fields that worked, pasted them in the cells where they didn't, changed the field names and still received the same inaccuracies.
Attached Files
File Type: docx DT15v1_5.docx (410.2 KB, 0 views)
File Type: docx letters3.docx (386.9 KB, 1 views)
Reply With Quote
  #11  
Old 04-11-2016, 07:47 PM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

This is ALT-F9 view of your report.

The field on the left in red produces the correct results. The one on the right not.
I do not see any differences between the two except for the field references (r3 vs. r4)

Reply With Quote
  #12  
Old 04-11-2016, 08:17 PM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

I can only conclude that differences between our systems mean they handle your workbook data slightly differently. Some of that may be related to your use of custom time formats that in cells that don't contain times. How about we start with the workbook and change all the formatting to 'General', then apply the data & time formats to the entire columns containing those data (dates - B, AP, AS, AV; times - N, O, Z, AB, DZ, EA, EC, ED). That way at least we might start talking on the same wavelength. See attached.
Attached Files
File Type: xlsx Aug-30 (Sun) schedule_3B.xlsx (24.0 KB, 3 views)
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #13  
Old 04-12-2016, 05:37 AM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

I downloaded your data source file, and placed it in a directory dedicated to your contributions to this project. I'm confirming that all times and dates are in the proper format (as your instructions eluded), with the exception of the r1 through r_8 srl and sru times which are decimal. This is the format of the report you sent

I then re-downloaded your merge document (report) from post #2, and put it in the same directory.

I opened up the report with Word, selected your data file and worksheet "CORE" as its recipient (source). From 'Edit Recipients' I selected "DT" from the type field.

'Preview Results' : (attachment)



Still the same

Select 'Finish & Merge' > 'Edit Individual documents' ...
Get a "Field calculation error occured in record 1", and saved the resulting document.

I've attached the completed document.

As an aside ... when I went to save the document, it insisted on giving it the name of 1.docx, while the document title was letters2. Is this normal? I would have thought it would want to save it as the same name as the document title.

I don't know Paul. Gremlins?
Attached Files
File Type: docx 1.docx (386.7 KB, 0 views)
Reply With Quote
  #14  
Old 04-12-2016, 06:22 AM
macropod's Avatar
macropod macropod is offline Unable To Get Proper Merged Results Windows 7 64bit Unable To Get Proper Merged Results Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,524
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Quote:
Originally Posted by JennEx View Post
I downloaded your data source file, and placed it in a directory dedicated to your contributions to this project. I'm confirming that all times and dates are in the proper format (as your instructions eluded), with the exception of the r1 through r_8 srl and sru times which are decimal. This is the format of the report you sent
My bad. I've replaced that file with the time formats corrected. Try the new version.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #15  
Old 04-12-2016, 06:59 AM
JennEx JennEx is offline Unable To Get Proper Merged Results Windows XP Unable To Get Proper Merged Results Office 2013
Competent Performer
Unable To Get Proper Merged Results
 
Join Date: May 2010
Posts: 158
JennEx is on a distinguished road
Default

Where did you put the new version (data file or report file) ...?

And so we're on the same page, (I'm guessing you have reason behind your approach), but I don't seem to be having issues with the time fields. It's the others line: r#_relchg, r#_crew, r#_division, r#_base and r#_pitch that are being represented improperly in the report.

For example, the boxes under "CHANGE" shouldn't have any time values in them which a couple do (They are supposed be be simply "r#_division r#_base/r#_pitch ... Bantam 82'/55', not ). When I look at both your formula and mine, I don't even see any reference to time fields, nor is the data for those respective fields time.

I wonder ... the text values in the data for r#_base and r#_pitch include an apostrophe. (82', 55'). Might this be causing issues?
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
proper snoforlife Excel Programming 0 01-26-2016 02:16 PM
Unable To Get Proper Merged Results Hyperlinks Not Linking to Proper Sections of Doc MoiraB Word 2 08-26-2015 07:13 PM
Unable To Get Proper Merged Results Table will not allow sorting because "cells are merged". I can't find the merged cells. wendyloooo Word Tables 1 05-26-2015 01:19 PM
Proper Text Format sufian,naeem Excel 1 05-05-2014 05:59 AM
2013 search results take a long time - they fill in as results in reverse date order themookman Outlook 0 10-11-2013 12:01 PM


All times are GMT -7. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft