Microsoft Office Forums Mail Mege Images - Path Correct but Images Repeated

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 04-20-2011, 10:58 AM
Sonia Sosa Sonia Sosa is offline Mail Mege Images - Path Correct but Images Repeated Windows Vista Mail Mege Images - Path Correct but Images Repeated Office 2003
Novice
Mail Mege Images - Path Correct but Images Repeated
 
Join Date: Apr 2011
Posts: 5
Sonia Sosa is on a distinguished road
Default Mail Mege Images - Path Correct but Images Repeated

Hi all,

I am putting together a catalog so I have 9 images with their respective descriptions per page.



The problem: Correct Code Same Image Being pulled
Although the code shows that the correct file name is being pulled, when I toggle to show the actual image only the first image (in the Excel sheet) is shown throughout the catalog. For example although the code shows 1,jpg, 2.jpg, 3.jpg, the image shown through the whole catalog is 1.jpg. However all the other text data is being shown correctly. Any ideas on what I am doing wrong?

In order to better understand what I have already accomplished and for others having similar problems. This is what I have fixed:

1. Need double dashes for the path:
{ INCLUDEPICTURE "c:\\CatalogPictures2\\Rings\{MERGEFIELD” “Product_Image_File1} \MERGEFORMAT\d}

2. Code changing on Save or Merge

I would put:
{ INCLUDEPICTURE "c:\\CatalogPictures2\\Rings\{MERGEFIELD” “Product_Image_File1} \MERGEFORMAT\d}

But when I merged or saved it would automatically change to:

{ INCLUDEPICTURE "../../../../../CatalogPictures2/{MERGEFIELD” “Product_Image_File1} \MERGEFORMAT\d}

Note: Both options pull the correct image

Fix: Go to, Tools/Options/General/Mail Options/ and unselect "Update links on Save"

3. Switch between viewing the code and the actual data
The way I was able to accomplish this was by going to:

Fix:
Tools/Options/View/show/
Select "Field Code" (sorry if that is not exact my version is in Spanish) to show code
Unselect to show data (including pictures)

4. Mail Merge for Images does not work in text boxes
Fix: Eliminated the text boxes and used another layout

5. Same data being pulled on for each entry
Only the firt line of the Excel sheet was being pulled.

Fix: In order to overcome this issue after the first entry add {Next Record}for every following entry. Example:

{Next Record} { INCLUDEPICTURE "c:\\CatalogPictures2\{MERGEFIELD” “Product_Image_File1} \MERGEFORMAT\d}

Furthermore, you only have to use the {Next Record}once for each data set. In other word each data set (example 3 per page) consists of:

Image, Title, Description, and Price

Only use {Next Record} before the image (or first item of data set). you do not need to add {Next Record} to the title, description, or price.
Reply With Quote
  #2  
Old 04-20-2011, 02:53 PM
macropod's Avatar
macropod macropod is offline Mail Mege Images - Path Correct but Images Repeated Windows 7 32bit Mail Mege Images - Path Correct but Images Repeated Office 2000
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,535
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Hi Sonia,

The field code syntax you posted is incorrect - the quote marks are in the wrong places and part of the '\* MERGEFORMAT' switch is missing. plus you don't need the '\* MERGEFORMAT' switch. Coding the field as:
{INCLUDEPICTURE "c:\\CatalogPictures2\\Rings\\{MERGEFIELD Product_Image_File1}" \d}
or:
{INCLUDEPICTURE "c:/CatalogPictures2/Rings/{MERGEFIELD Product_Image_File1}" \d}
will work.
As you found:
1. the pictures usually won't show correctly. You can refresh the fields (eg Ctrl-A, then F9) to get this to happen; and
2. even after updating the images, they remain linked to the image files, which can be an issue if you need to send the merged output to someone else.

The following field construction addresses both issues (and you only need one backslash for the path separators):
{IF {INCLUDEPICTURE {IF TRUE "c:\CatalogPictures2\Rings\«Product_Image_File 1»"} \d} {INCLUDEPICTURE {IF TRUE "c:\CatalogPictures2\Rings\«Product_Image_File 1»"} \d}}
or
{IF {INCLUDEPICTURE {IF TRUE "c:\CatalogPictures2\Rings\{MERGEFIELD Product_Image_File1}"} \d} {INCLUDEPICTURE {IF TRUE "c:\CatalogPictures2\Rings\{MERGEFIELD Product_Image_File1}"} \d}}

After running a mailmerge coded this way, you'll have the correct, unlinked image for each record.

To toggle the field code display on/off, simply press Alt-F9.

Using a {Next Record} field in a letter merge or a directory/catalog merge can also result in records being skipped. For your purposes, what you're generating is the same as a label merge - which is why the {Next Record} field is needed. For a letter merge or a label merge, you should not have a {Next Record} field after the last item on the page.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #3  
Old 04-20-2011, 09:44 PM
Sonia Sosa Sonia Sosa is offline Mail Mege Images - Path Correct but Images Repeated Windows Vista Mail Mege Images - Path Correct but Images Repeated Office 2003
Novice
Mail Mege Images - Path Correct but Images Repeated
 
Join Date: Apr 2011
Posts: 5
Sonia Sosa is on a distinguished road
Default

Thank you for the information. Unfortunately neither option worked.

The refreshing did not work using Ctrl-A, then F9. Is there any other way to refresh?
And I used your code and that didn't return anything, no image, all that shows is {IF

I am really stuck, do you think maybe there is a bug in my software? Some setup problem?
Reply With Quote
  #4  
Old 04-20-2011, 09:57 PM
macropod's Avatar
macropod macropod is offline Mail Mege Images - Path Correct but Images Repeated Windows 7 32bit Mail Mege Images - Path Correct but Images Repeated Office 2000
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,535
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Hi Sonia,

Ctrl-A, F9 updates all fields in the body of a document. If you did that and nothing happened, then either:
• you're looking at your mailmerge main document and not the merged output; or
• there are no fields in the body of the document

As for the field code I posted not working for you, that suggests you haven't replicated all the field braces correctly. The field brace pairs (ie '{ }') in the field examples are created via Ctrl-F9 - you can't simply type them or copy & paste them from this message. Likewise, you can't type or copy & paste the chevrons (ie '« »') - they're part of the actual mergefields, which you can insert from the mailmerge toolbar.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #5  
Old 04-22-2011, 03:51 AM
Sonia Sosa Sonia Sosa is offline Mail Mege Images - Path Correct but Images Repeated Windows Vista Mail Mege Images - Path Correct but Images Repeated Office 2003
Novice
Mail Mege Images - Path Correct but Images Repeated
 
Join Date: Apr 2011
Posts: 5
Sonia Sosa is on a distinguished road
Default

Hi,

Ctrl A-F9 - I definately think there is something wrong with my keyboard or somethng else, because I if I do ctrl A, and then F9, F9 onpens the built in camera, if I do them combined it inputs a curly bracket. And yes there are definately fields in the document..

Field code - With regards to the code you gave me I did copy and paste it, but I still could have done something to mess it up. I have attached the document (only replaced the first set). Please take a look at it and let me know.

Thanks again for all your help,

Sonia
Attached Files
File Type: doc Catalogo Nuevo Modelo 3 New Code.doc (57.0 KB, 15 views)
Reply With Quote
  #6  
Old 04-22-2011, 05:27 AM
macropod's Avatar
macropod macropod is offline Mail Mege Images - Path Correct but Images Repeated Windows 7 32bit Mail Mege Images - Path Correct but Images Repeated Office 2000
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,535
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Hi Sonia,

Your field code appears to have omitted part of the path. Try the attached. I've also changed the layout to a table one, as that should make it easier for you to control the area available to each item.

Note: Because I don't have your data source, the attached document will need to have that re-attached before it will work as a mailmerge document again.
Attached Files
File Type: doc Catalogo Nuevo Modelo 3.doc (61.5 KB, 23 views)
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #7  
Old 04-22-2011, 01:08 PM
Sonia Sosa Sonia Sosa is offline Mail Mege Images - Path Correct but Images Repeated Windows Vista Mail Mege Images - Path Correct but Images Repeated Office 2003
Novice
Mail Mege Images - Path Correct but Images Repeated
 
Join Date: Apr 2011
Posts: 5
Sonia Sosa is on a distinguished road
Default

Thank you so much for taking the time to do this. Unfortunately all I get is a frame with an x. furthermore in the merged document I can't see the code when I switch between views. Any ideas what could be going wrong?
Reply With Quote
  #8  
Old 04-22-2011, 02:37 PM
macropod's Avatar
macropod macropod is offline Mail Mege Images - Path Correct but Images Repeated Windows 7 32bit Mail Mege Images - Path Correct but Images Repeated Office 2000
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,535
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Hi Sonia,

In your original post, you gave the path as "c:\CatalogPictures2\Rings\", but in the document you posted, it was "c:\CatalogPictures2\". So, believing you may have omitted 'Rings\" in error, I included it in the modified document I posted. If you're still not getting an image, I can only conclude that the path is still wrong. Can you tell me what the:
• correct path is; and
• 'Product_Image_File1' records contain (ie the actual text from a record)?

As for the mergefields not showing in the output, that is normal. The fields get converted to their results as part of the merge process and the fields are deleted.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #9  
Old 04-22-2011, 03:05 PM
Sonia Sosa Sonia Sosa is offline Mail Mege Images - Path Correct but Images Repeated Windows Vista Mail Mege Images - Path Correct but Images Repeated Office 2003
Novice
Mail Mege Images - Path Correct but Images Repeated
 
Join Date: Apr 2011
Posts: 5
Sonia Sosa is on a distinguished road
Default

I don't know you, but I love you! You were right, the file path was wrong. Thank you! Thank you! Thank you!
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Mege Images - Path Correct but Images Repeated Inserted images don't appear terence_laoshi Drawing and Graphics 2 04-14-2011 05:08 AM
Powerpoint images sharon_1985 PowerPoint 0 08-02-2010 11:47 PM
Compressing images Fran PowerPoint 0 10-29-2009 07:18 AM
Inserting images into mail merge lorraine_hamilton Mail Merge 0 10-19-2009 09:55 AM


All times are GMT -7. The time now is 01:09 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft