Microsoft Office Forums Mail merge problems

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 12-13-2014, 09:03 PM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default Mail merge problems

Here's what I've done so far, using Word 2007. By the way, at what point do I choose a font? Tried changing the font before starting mail merge, had no effect.



Mailings > Start Mail Merge > Step by Step Wizard

Labels > Label options > Office Depot Address 612-011 (8.5x11 page)

Select recipients > Browse > Excel 2007 file > Open

Show All > MS Excel Worksheets via DDE > Entire Spreadsheet > OK (all recipients checked)

Arrange labels > Address block > OK > Update all labels

I think this is where the problem occurs - it adds AddressBlock only to the top 3 labels and the last 2 labels on the page. All other labels still read Next Record with no AddressBlock. Am I missing something?
Reply With Quote
  #2  
Old 12-13-2014, 09:19 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

The 'Update all labels' process should propagate the setup from the first label to all others on the page. If it doesn't do so, you should still be able to copy the content from any of the populated labels and paste its content into the others (just make sure each label ends up with only one «NextRecord» field.

Two additional points:
1. DDE is old technology that has been superseded by both ODBC and its successor, OLE DB. You should only use DDE as a last resort, as it only works with the first worksheet in the workbook, and only for named ranges that names that reference the first sheet and have either workbook scope or the same scope as the sheet.
2. The Address Block often does a poor job of managing address layouts, including being unable to suppress blank lines in an address. You're generally better off inserting the required mergefields, where required, and using the available switches, etc. for controlling blanks lines, etc.

PS: Please post mailmerge questions in the mailmerge forum (to which I've moved your post).
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #3  
Old 12-14-2014, 12:13 AM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Thanks Paul. Tried OLE DB but Update All Labels is still propagating to only a few of the labels, not all of them. Highlighted NextRecord AddressBlock and copy/pasted to each label, but still getting only sporadic results on preview - many of the labels have not been replaced with the actual addresses. Any ideas? Thanks! ...Steve
Reply With Quote
  #4  
Old 12-14-2014, 12:36 AM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

The 'Update All Labels' button has nothing to do with the connection method, so I'm not surprised changing the former had no effect on the latter.

Previews are not a reliable indicator of the final output - to see what will print, send the output to a new document.

Without actually seeing the problem mailmerge main document and source data, it can be difficult for anyone to diagnose the issue. Can you attach the document to a post with some sample data (delete anything sensitive)? You do this via the paperclip symbol on the 'Go Advanced' tab at the bottom of this screen.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #5  
Old 12-14-2014, 08:47 AM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Thanks Paul. I'm not sure how to send the output to a new document. I've attached the page with «Next Record»«AddressBlock», may not work without the spreadsheet attached?
Attached Files
File Type: doc 1 AddressBlock.doc (36.0 KB, 4 views)
Reply With Quote
  #6  
Old 12-14-2014, 11:05 AM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Here's a sample Excel file to attach to the labels
Attached Files
File Type: xlsx TEST MAILING LABELS.xlsx (10.5 KB, 4 views)
Reply With Quote
  #7  
Old 12-14-2014, 01:47 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

The document in your attachment has no actual mergefields in it - they've all been converted to text. When I delete all the label contents, then insert a new AddressBlock field and click on 'Update Labels', the records propagate just fine. Given that your attached workbook has just the same name & address throughout, it evidently isn't just a copy of your original with the details changed for privacy, so I'm not sure how valid the results are. That said, the merge to a new document works fine.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #8  
Old 12-14-2014, 04:15 PM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Thanks Paul. When you refer to deleting the label contents, you mean all the «Next Record»«AddressBlock» fields? And then replaced them with a new «AddressBlock» field?

Attached is a jpg of what happens when I use the same list I sent you and then click Update All Labels. It propagates AddressBlock across the top row and the last two records on the page (which do not appear in the jpg). All the other records appear the same as before I clicked Update, with no AddressBlock.
Attached Images
File Type: jpg 1 addressblock.jpg (57.9 KB, 41 views)
Reply With Quote
  #9  
Old 12-14-2014, 04:42 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Quote:
Originally Posted by weamish View Post
Thanks Paul. When you refer to deleting the label contents, you mean all the «Next Record»«AddressBlock» fields? And then replaced them with a new «AddressBlock» field?
Exactly, except that there were no «Next Record»«AddressBlock» fields in your attachment - what was there was mere «Next Record»«AddressBlock» text - plus four cells at the top & two at the end with your 'Bill Smith' addresses. Try the attached update - simply reconnect to your datasource as a label merge.
Attached Files
File Type: docx Weamish.docx (24.7 KB, 12 views)
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #10  
Old 12-14-2014, 06:26 PM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Thanks so much Paul, you're a lifesaver! I can't for the life of me figure out what I was doing wrong, particularly ending up with plain text rather than data fields. Would it be ok with you if I send along a detailed list of steps I followed, so we can maybe determine where I went wrong? ...Steve
Reply With Quote
  #11  
Old 12-14-2014, 06:51 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

Sure, though from what I can make of your document, I think the problem probably arose out of a copy/paste operation where the fields were copied then pasted as plain text.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #12  
Old 12-17-2014, 02:05 PM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Mailings > Start Mail Merge > Labels > OfficeDepot > Address 612-011 > OK

Mailings > Select Recipients > Use Existing List > Open > Sheet1 > Check box re: data headers > OK

Mailings > Address Block > OK

Mailings > Update Labels

This is where it goes off the rails - AddressBlock appears only on the top row of 3 labels and on the last 2 labels on the page. This error is confirmed in Preview Results.

Any idea what I'm doing wrong?

Thanks!
Reply With Quote
  #13  
Old 12-17-2014, 02:16 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

That process look OK. Perhaps there's a fault in your Office installation or you have a rogue 3rd-party Addin that's messing things up. Have you tried repairing the Office installation (via Start > Windows Control Panel > Programs > Programs & Features > Microsoft Office (version) > Change)?
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
  #14  
Old 12-17-2014, 02:38 PM
weamish weamish is offline Mail merge problems Windows Vista Mail merge problems Office 2007
Advanced Beginner
Mail merge problems
 
Join Date: Dec 2011
Posts: 57
weamish is on a distinguished road
Default

Thanks Paul. I'm not running any add-ins, and MS Office diagnostics found no problems. Feels like I'm doomed. Sigh...
Reply With Quote
  #15  
Old 12-18-2014, 03:19 PM
macropod's Avatar
macropod macropod is offline Mail merge problems Windows 7 64bit Mail merge problems Office 2010 32bit
Administrator
 
Join Date: Dec 2010
Location: Canberra, Australia
Posts: 19,599
macropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to beholdmacropod is a splendid one to behold
Default

FWIW, a repair won't necessarily tell you what it may have fixed.
__________________
Cheers,
Paul Edstein
[MS MVP - Word]
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Merge Problems jmac12 Outlook 2 07-04-2018 01:14 PM
Mail Merge is Deleting objects in my header and footer during the merge bgranzow Mail Merge 9 06-05-2015 05:03 AM
Mail merge how to link mail merge field value to a column heading dsummers Mail Merge 1 05-08-2014 02:59 PM
Mail merge problems Problems with mail merge Joanne Mail Merge 1 09-29-2013 07:24 PM
Mail merge problems Merge to e-mail: two problems MartinD_UK Mail Merge 15 06-19-2012 11:23 PM


All times are GMT -7. The time now is 03:44 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft