Microsoft Office Forums

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 06-16-2014, 08:17 PM
Abumushfiq Abumushfiq is offline Strange Excel Behaviour with ACE OLEDB Provider Windows 7 64bit Strange Excel Behaviour with ACE OLEDB Provider Office 2010 32bit
Novice
Strange Excel Behaviour with ACE OLEDB Provider
 
Join Date: Jun 2014
Posts: 2
Abumushfiq is on a distinguished road
Default Strange Excel Behaviour with ACE OLEDB Provider

Hi Everyone,



In our MSBI assignment, we are having separate environment for TEST and Production respectively.

We are fetching the Excel file from SharePoint and loading into SQL Server
using SSIS. So as said, each of these module will have similar setup in both environments.

Our issue is with an Excel file from PROD sharepoint is not loaded properly thorugh ACE OLEDB 12 proivider. It is loading null for few cells. which was working so far earlier.

Following are our attempts to fix the issue:

1. We took the file from PROD and drop it in TEST sharepoint, there it is getting loaded fine.
2. We took the SSIS package from Production code and deployed the same into TEST, there it is working fine picking the files from TEST sharepoint.
3. With several other attempts, we confirmed that there is no issue with Excel source file, SSIS package etc.
4. Then on researching further, we found that there is a difference in system registry of the servers. In TEST server, ACEEXCL dll from Office 14 is referred as Excel Engine. whereas in Production ACEEXCL dll from Office 12 is referred as Excel Engine. Attaching snapshots for your reference.
5. We also tried modifying TypeGuessRows (as you see in the snapshot there is difference in this settings too), but it doesn't work out.

Please confirm the above difference and let me know the steps to fix this if it is the cause. If not kindly key down your valuable suggestions to proceed further.

Thanks
AbuMushfiq


Regards,
AbuMushfiq
Attached Images
File Type: jpg Production_Snp.jpg (134.0 KB, 15 views)
File Type: jpg TEST_Snp.jpg (164.8 KB, 15 views)
Reply With Quote
  #2  
Old 06-30-2014, 04:20 AM
Abumushfiq Abumushfiq is offline Strange Excel Behaviour with ACE OLEDB Provider Windows 7 64bit Strange Excel Behaviour with ACE OLEDB Provider Office 2010 32bit
Novice
Strange Excel Behaviour with ACE OLEDB Provider
 
Join Date: Jun 2014
Posts: 2
Abumushfiq is on a distinguished road
Default

Hi All,

The issue is resolved by changing the TypeGuessRows from 8 to 0. All we need to do is we need to exit the Registry editor once after the change.

Thanks
Abumushfiq
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Image attachments opening with strange behaviour mothman Outlook 0 02-16-2013 08:53 PM
Strange behaviour when entering Actuals joday48 Project 4 01-15-2013 03:51 AM
Referencing a value over 255 characters within a table PLUS strange formula behaviour TishyMouse Excel 2 01-08-2013 09:39 AM
Best Mobile Service Provider! Nethrom Outlook 0 11-14-2011 02:10 PM
how to install MS Project OLEDB Provider pascali Project 0 02-24-2006 07:46 AM

Other Forums: Access Forums

All times are GMT -7. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft