Microsoft Office Forums

Go Back   Microsoft Office Forums > >

Reply
 
Thread Tools Display Modes
  #1  
Old 07-05-2011, 07:49 AM
EMH EMH is offline Macros not working when template is emailed Windows XP Macros not working when template is emailed Office 2010 32bit
Novice
Macros not working when template is emailed
 
Join Date: Jul 2011
Posts: 1
EMH is on a distinguished road
Default Macros not working when template is emailed

I am creating a macro enabled template in Word 2010 for someone. I have some really basic macros e.g. inserting an autotext (as the end user is more familiar with macros than autotexts). When I look at the code, it references where the template is saved i.e. my C drive. If I email this template it still points to this location, and therefore won't run (run time error 5941 - the requested member of the collection does not exist). Do I just take out everything except the template name or do I need to add something else? Is there a way to update macros to reflect being saved to a different location - it seems crazy that they're not just simply attached to a file no matter where it is?
Reply With Quote
  #2  
Old 07-06-2011, 09:24 AM
OTPM OTPM is offline Macros not working when template is emailed Windows 7 32bit Macros not working when template is emailed Office 2010 32bit
Expert
 
Join Date: Apr 2011
Location: West Midlands
Posts: 981
OTPM is on a distinguished road
Default

Hi
First of all this should be posted in the Office section not the Excel section.
Are you saving the template as a macro enabled template?
Also are you saving the macro in the template rather than the normal template when you create it.
Hope this helps.
Tony (OTPM)
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
emailed outlook calendar not working Tankerman Outlook 0 12-08-2010 10:36 AM
Macros not working when template is emailed Macros not working in word 2010 louise_chapman Word VBA 3 10-25-2010 08:34 AM
Macro to open template not working Brandi Mail Merge 2 06-24-2010 09:29 AM
Macros not working when template is emailed Discover if Macros exist in template or document jimbassett Excel 2 02-08-2010 08:06 AM
Word field stops working on template launch anakeimai Word 0 09-10-2009 08:49 AM

Other Forums: Access Forums

All times are GMT -7. The time now is 03:15 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
MSOfficeForums.com is not affiliated with Microsoft